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Welcome to PriceWise Calculator Pro! -

So you've decided to use PriceWise Calculator Pro for your WooCommerce store - awesome
choice! Whether you're selling custom t-shirts, offering landscaping services, or running any
business where prices depend on customer choices, this plugin's got your back.

What Makes This Plugin Special?

% The Interface is Gorgeous

We're talking about a modern, slider-based interface that looks like it belongs in 2025. Your
customers move through the calculator step-by-step, with progress tracking showing them
exactly where they are.

Customization That Actually Works

You get 15+ different color controls with an enhanced color picker that lets you either click
and choose visually OR type in hex codes. Whatever works for you.

g It Just Works with WooCommerce

The calculator integrates seamlessly with your products. Customers configure what they
want, the price updates in real-time, and when they add to cart - boom - the custom price and
all their selections go right along with it.

Installation Guide

Minimum Requirements

e WordPress 5.8 or greater
e PHP version 7.4 or greater
e WooCommerce 5.0 or greater (for full functionality)

e MySQL version 5.6 or greater



Automatic Installation

Log in to your WordPress dashboard
Navigate to Plugins > Add New
Search for "PriceWise Calculator Pro" or upload the plugin ZIP file

Click "Install Now"
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After installation, click "Activate Plugin”

Manual Installation

Download the plugin ZIP file
Log in to your WordPress dashboard
Navigate to Plugins > Add New > Upload Plugin

Choose the downloaded ZIP file and click "Install Now"
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After installation, click "Activate Plugin"

After Activation

After activating the plugin, you'll see a new "Calculators" menu in your WordPress admin
sidebar. You're ready to create your first calculator!

Setting Up Your First Calculator

Step 1: Head to the Dashboard

1. Go to Calculators > Dashboard
2. You'll see your stats (zero for now) and quick action buttons

3. Click the "Add New Calculator" button

Step 2: The Basic Info Tab

The plugin uses a tabbed interface with 4 main tabs. You start on the Basic tab.



What's in the Basic Tab:

¢ Calculator Name - The title users will see (e.g., "Custom T-Shirt Calculator")
e Description - Optional description to help users understand what this calculator does

¢ Assignment Strategy - Choose where your calculator appears:

o Global Calculator - Automatically applies to ALL WooCommerce products
o Product Calculator - Tied to specific products
o Category Calculator - Applied to entire product categories

e Category Selection - When you pick "Category Calculator" above, select which
WooCommerce categories this calculator should appear on

Step 3: The Formula Tab

Click over to the Formula tab. This is where you set up how the calculator actually calculates
prices.

You'll configure:

e Base Price - Starting price for calculations

e Formula - How field values affect the final price using mathematical operators (+, -, *, /)

Step 4: The Fields Tab - Where the Magic Happens

Click on the Fields tab to actually build your calculator.

Available Field Types (8 Total):

. Text Input - For names, custom text, or any text info
. Number Input - For quantities, measurements, dimensions
. Dropdown - When you want to give them a list of options

. Radio Buttons - Multiple choice, but they can only pick one

. Slider - A visual way to pick numbers

1

2

3

4

5. Checkboxes - Let them select multiple options

6

7. File Upload - When customers need to upload files
8

. Textarea - For longer text input and special instructions

For each field, configure:

e Field Type



Label (what customers see)

Field Key (used in formulas)

Required or Optional

Options (for dropdowns, radios, checkboxes)

Validation rules

Step 5: Settings Tab

Control publication settings and behavior:
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Set calculator as Active or Inactive. Only active calculators show to
users.

Status

Control display order when multiple calculators are assigned (1-100,

Priorit
riority default is 1)

Hide Quantity

Check this to hide the quantity input field on product pages
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Step 6: Save It!

Hit the "Save Calculator" button and you're done! Your calculator is now ready to assign to
products.

Managing Your Calculators

Once you've created calculators, manage them at Calculators > All Calculators.

Features:

Grid View vs. List View - Toggle between card view and table view

Search & Filter - Find calculators quickly

Quick Actions - Edit, Duplicate, or Delete

Bulk Actions - Manage multiple calculators at once

Styling Your Calculators to Match Your
Brand



Go to Calculators > Settings and click the Design tab.

The Enhanced Color Picker System

You'll see multiple color pickers for:

e Header Background

e Title Text

e Calculator Background
e Button Colors

e Progress Bar Colors

e |Input Field Colors

e And more...

Each color picker allows you to:

e Click to select visually

¢ OR type hex codes directly

Connecting Calculators to Your Products

You have THREE powerful ways to assign calculators:

1. Global Calculator (Easiest)

e Set in the Basic tab: choose "Global" in Assignment Strategy
e Your calculator automatically appears on ALL WooCommerce products by default

e Perfect when most of your products use the same pricing structure

2. Product Calculator (Specific)

For individual products that need their own calculator:

Edit your product in WooCommerce

Go to the "Product Data" section

1.

2.

3. Click on the "Calculator" tab

4. Select which calculator to assign
5.

Save the product



3. Category Calculator (Powerful)

Assign one calculator to an entire category - every product automatically gets it!

To set this up:

1. In your calculator's Basic tab, choose "Category" in Assignment Strategy
2. The category selector appears - check all categories you want

3. Save the calculator

s Priority Order:

Product Calculator - Category Calculator - Global Calculator

So if a product has its own calculator assigned, that takes priority over everything else.

The Frontend Experience

When customers visit a product with a calculator, they see a beautiful slider-based interface
instead of a fixed price.

Features:

e Step-by-step navigation ("1 of 5" progress)
e NEXT - and « PREV buttons
e Real-time price updates in persistent footer

e Modern, mobile-friendly design

Field validation with helpful error messages

Customers fill in fields, click "Next" to move through steps, and the price updates in real-time.
When they hit "Add to Cart", the custom price and ALL their selections are saved with the
order!

Common Issues & Solutions

A MOST COMMON ISSUE: Calculator Not Showing on
Product Page



The Problem:

You've assigned a calculator but it doesn't appear on the frontend.

The Solution - Check These TWO Critical Things:

1. Your Calculator MUST Have At Least One Input Field

You can't just create a calculator and assign it - you need to add fields in the Fields tab!
How to fix:

. Go to your calculator in the admin

. Click the "Fields" tab

1
2
3. Add at least one field
4. Save the calculator
5

. Refresh your product page - it should now appear!

v Calculator with 1+ fields = Shows on frontend

X Calculator with 0 fields = Hidden (won't display)

2. Your WooCommerce Product MUST Have a Price Set

WooCommerce requires a base price, even if your calculator replaces it.
How to fix:

1. Edit the product in WooCommerce

2. Set a Regular Price (any number like $10)
3. Save the product
4

. The calculator will now display and replace this price

v Product with price ($10) + Calculator = Calculator works

X Product with NO price + Calculator = Calculator won't display



Quick Checklist:

[0 Calculator has at least 1 field added?

[0 Product has a regular price set?

If BOTH are yes, your calculator should display!

Calculator Shows But Price Doesn't Update

The Problem: Calculator displays but price stays the same when making selections.

The Solution:

Go to Calculators > Edit your calculator

Check the Formula tab

1.
2.
3. Verify your formula uses correct field keys with curly braces: {field key}
4. Make sure field keys match EXACTLY (case-sensitive)

5.

Test the formula - the plugin validates it for you

Calculator Looks Weird/Broken on Frontend

The Solution:

e Check for theme conflicts - test with a default WordPress theme (Twenty Twenty-Four)
e Check for CSS conflicts - inspect browser console for errors
e Verify you're not using custom CSS that conflicts

e Clear all caches (WordPress cache, browser cache, CDN cache)

Multiple Calculators Appear on Same Product

The Solution:

Check if product has calculator assigned directly in Product Data

Check if product's category has calculator assigned

1.

2.

3. Check if Global calculator is active

4. Use Priority setting in Settings tab to control which displays
5.

Remove duplicate assignments

Remember: Product Calculator > Category Calculator > Global Calculator



Still Stuck? &)

If you've tried everything and your calculator still isn't working:

Double-check the TWO critical requirements (fields + price)
Make sure calculator Status is set to "Active" in Settings tab
Verify WooCommerce is installed and active

Test with a default WordPress theme

Check WordPress debug.log for PHP errors
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Contact support (see last page)

Real-World Example: Custom T-Shirt Shop

Let me walk you through a COMPLETE example from start to finish.

Scenario

You're selling custom t-shirts with dynamic pricing based on style, size, print type, quantity, and
add-ons.

STEP 1: Basic Info Tab

Calculator Name Custom T-Shirt Price Calculator
Description Configure your custom t-shirt and get an instant price quote
Assignment Strategy Category Calculator

Custom T-Shirts

Select Categories
9 Apparel

STEP 2: Fields Tab - Create Your Input Fields

Field #1: T-Shirt Style (Dropdown)

¢ Field Type: Dropdown

e Label: "Choose Your T-Shirt Style"
¢ Field Key: tshirt style

e Required: Yes

e Options:



o Basic Cotton (value: basic, price: 0)
o Premium Soft Blend (value: premium, price: 5)

o Vintage Distressed (value: vintage, price: 8)

Field #2: Size (Dropdown)

¢ Field Type: Dropdown
e Label: "Select Size"
e Field Key: size
¢ Required: Yes
e Options:
o Small (value: s, price: 0)
o Medium (value: m, price: 0)

o Large (value: |, price: 0)

o

XL (value: xl, price: 2)

o

2XL (value: 2xl, price: 4)

o

3XL (value: 3xl, price: 6)

Field #3: Print Type (Radio Buttons)

Field Type: Radio Buttons

Label: "Choose Print Method"

Field Key: print_type

Required: Yes

Options:

o Screen Print (value: screen, price: 0)
o Direct-to-Garment (value: dtg, price: 3)

o Vinyl Heat Transfer (value: vinyl, price: 5)

Field #4: Quantity (Number Input)

Field Type: Number Input

e Label: "How Many T-Shirts?"
e Field Key: guantity

¢ Required: Yes

e Min Value: 1

e Max Value: 500

¢ Default Value: 1

Field #5: Rush Order (Checkbox)



¢ Field Type: Checkbox

e Label: "Rush Order (2-Day Production)"
¢ Field Key: rush order

e Required: No

e Price if Checked: 15

Field #6: Gift Packaging (Checkbox)

¢ Field Type: Checkbox
Label: "Add Gift Packaging"

Field Key: gift_packaging

Required: No

Price if Checked: 5

STEP 3: Formula Tab - Set Up Your Pricing Logic

Base Price: $15

(Starting price for a basic t-shirt with screen print)

Formula:

(15 + {tshirt_style} + {size} + {print_type} + {rush_order} + {gift_ packaging}) * {quant:

L 2

2 How The Formula Works:

The formula uses curly braces {3 around field keys to reference their values:

e 15 = Base price for any t-shirt

e (tshirt_style} = Adds $0 for Basic, $5 for Premium, or $8 for Vintage
e {size} = Adds $0 for S/M/L, $2 for XL, $4 for 2XL, $6 for 3XL

e (print_type} = Adds $0 for Screen, $3 for DTG, or $5 for Vinyl

e {rush order} = Adds $15 if checked, $0 if not checked

e {gift_packaging} = Adds $5 if checked, $0 if not checked

e {guantity} = The number customer enters (multiplies the whole total)

. Example Calculation:

Customer orders: Premium Soft Blend, XL, DTG Print, Quantity 3, with Rush Order



(15 +5 + 2 + 3 + 15 + 0) * 3
= 40 * 3
= $120 TOTAL

Breakdown:

15 = base price
e 5 = premium t-shirt

e 2 = XL size

3 = DTG print

15 = rush order

0 = no gift packaging
e X 3 = quantity of 3 shirts

‘@* Formula Tips:

e Always use curly braces {3 around field keys

¢ Field keys must match EXACTLY (case-sensitive!)

e You can use: + (add), - (subtract), = (multiply), / (divide)
e Use parentheses () to control order of operations

e Checkboxes return their price if checked, 0 if unchecked

e Number fields return whatever number the customer enters

STEP 4: Settings Tab

m

Status Active
Priority 1 (default is fine)
Hide Quantity Selector Yes (we're handling quantity in our calculator)

STEP 5: Save & Assign

1. Click "Save Calculator"

2. Since we chose "Category Calculator" in Step 1, it's already assigned to your Custom T-Shirts
category

3. Go to any product in that category - your calculator is live!



STEP 6: Critical Requirements

Remember:

[0 Your calculator HAS fields (we added 6!) v

[0 Your WooCommerce product MUST have a base price set

Result &

Your customers now see a beautiful, modern calculator that walks them through choosing
their t-shirt style, size, print method, and quantity. The price updates in real-time as they
make selections. When they hit "Add to Cart", the custom price and ALL their selections are
saved with the order!

Top Tips for Success

® Start Simple

Create a basic calculator with 3-5 fields first. Get comfortable with the interface before
building complex multi-step calculators.

# Test on Mobile First

More people shop on phones than you think. Always check how your calculator looks on a
small screen.

) Use the Duplicate Feature

Created a great calculator? Duplicate it and modify it rather than starting from scratch each
time.




Export Regularly

Once a month, export your calculators. It's the easiest backup you'll ever make.

Brand Your Colors

Take 10 minutes to set up your brand colors in the Design settings. It makes such a
difference.

s Keep Steps Short

3-7 steps is the sweet spot. More than that and people start dropping off.

Support & Resources

Z Full Documentation (Online)

For the most comprehensive, up-to-date documentation, tutorials, and
video guides:

https://devtonicstudios.com/documentation/

What's Available Online:

e Detailed step-by-step tutorials
e Video walkthroughs

e Advanced feature guides

e Integration tutorials

e Frequently Asked Questions

e Troubleshooting guides

e Community tips & tricks

& Website


https://devtonicstudios.com/documentation/

https://devtonicstudios.com
Visit our website for:

e Product updates

e Feature announcements

Blog posts and tutorials

Live demos

Customer showcase

22 Email Support

support@devtonicstudios.com
For technical support, please email us with:

e Your WordPress version

e Your WooCommerce version

Description of the issue

Screenshots (if applicable)

e Any error messages

Support Hours: Monday - Friday, 9 AM - 5 PM EST
Response time: Within 24 hours

& Support Portal

For faster support, use our dedicated support portal:
https://devtonicstudios.com/support/
Benefits:

e Track your support tickets

e Access knowledge base

e See common solutions

e Priority support for customers

Thank You!

Thank you for choosing PriceWise Calculator Pro! We're committed to helping you create amazing price
calculators that delight your customers and grow your business.

If you have any questions, suggestions, or feedback, we'd love to hear from you.

Happy Calculating!



— The Devtonic Studios Team
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